Jump to content


Black Screen Temp Fix (For Router Users)


  • Please log in to reply
468 replies to this topic

#1 Naj

Naj

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 July 2012 - 06:16 PM

I have been experiencing the Black Screen of Death (black screen, mouse cursor upon enter, can't hear sounds, WILL NOT DC automatically) during the past week intermittently and so I dug up around the net and on how to fix this but did not find anything that would work with my case.

Basically, each time I zone out (use a portal) towards an instance I get this annoying black screen. On some days I dont, but on other days DN will black screen on me completely for a whole day or more.

I tried using low settings, windowed mode and disabling sound and none of them seem to work (which would mean that the issue does not lie in my pc since I could play on WoW, Skyrim and BL:R with higher settings) I have also tried fresh reinstalls which also did not work.

Finally, I read somewhere that the black screen is just the game timing out on me and it was a network issue and at first I doubted my low bandwidth (1 mbps)

I tried to use a free VPN to test out the network theory and it worked! however, I was experiencing very high delay (1-2 seconds) and it was almost unplayable if going into pvp. well at least that solved the black screen problem. Then it hit me, what if it was some routing error since at  the time I was using a D-Link wireless router, so I tried bypassing the router and directly connecting the modem. Problem solved, no more black screen. Except that 3-4 people would also need the router since our household uses the net on a daily basis.

The final solution I thought of was port-forwarding for router users, so i would like to request the ports used for the game so we could configure our routers and avoid the black screen

#2 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 04 July 2012 - 07:26 PM

Update on the post for easier reading of new players. Read post here: http://forum.cherryc...40#entry1732708

second update: http://forum.cherryc...20#entry1984039



View PostNaj, on 04 July 2012 - 06:16 PM, said:

I have been experiencing the Black Screen of Death (black screen, mouse cursor upon enter, can't hear sounds, WILL NOT DC automatically) during the past week intermittently and so I dug up around the net and on how to fix this but did not find anything that would work with my case.

Basically, each time I zone out (use a portal) towards an instance I get this annoying black screen. On some days I dont, but on other days DN will black screen on me completely for a whole day or more.

I tried using low settings, windowed mode and disabling sound and none of them seem to work (which would mean that the issue does not lie in my pc since I could play on WoW, Skyrim and BL:R with higher settings) I have also tried fresh reinstalls which also did not work.

Finally, I read somewhere that the black screen is just the game timing out on me and it was a network issue and at first I doubted my low bandwidth (1 mbps)

I tried to use a free VPN to test out the network theory and it worked! however, I was experiencing very high delay (1-2 seconds) and it was almost unplayable if going into pvp. well at least that solved the black screen problem. Then it hit me, what if it was some routing error since at  the time I was using a D-Link wireless router, so I tried bypassing the router and directly connecting the modem. Problem solved, no more black screen. Except that 3-4 people would also need the router since our household uses the net on a daily basis.

The final solution I thought of was port-forwarding for router users, so i would like to request the ports used for the game so we could configure our routers and avoid the black screen
Ok. thanks for the information. I can extract the ports used by DN. be back in a few moments.

Edit: I'm back. Here's my scan.
there are 4 ports opened throughout opening and playing dragon nest.
  • During login:
    • Local port: 55638; remote address: 203.116.155.181; remote port: 14301; protocol: TCP
  • In-game:
    • Local port: 55641; remote address: 203.116.155.131; remote port: 14400; protocol: TCP
  • loading reminder messages throughout the game:
    • Local port: 55642; remote address: dn.cherrycredits.com; remote port: 80; protocol: TCP
  • Something during loading of map:
    • Local port: 62749; remote address: (doesn't show); remote port: (doesn't show); protocol: UDP

Edited by momona, 14 August 2013 - 02:11 PM.


#3 Naj

Naj

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 July 2012 - 08:34 PM

thanks, i will try to port forward the in-game port, since the log-in server works just fine even during routing. Although the *map loading* seems like the one causing the black screen? Since, I can log-in at any time and can wander around in towns buy using the ticket agent npc's. The main problem with black screen is during instances.

#4 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 04 July 2012 - 08:36 PM

View PostNaj, on 04 July 2012 - 08:34 PM, said:

thanks, i will try to port forward the in-game port, since the log-in server works just fine even during routing. Although the *map loading* seems like the one causing the black screen? Since, I can log-in at any time and can wander around in towns buy using the ticket agent npc's. The main problem with black screen is during instances.
I haven't actually read the ports open when i go outside of town. I'll try again soon.

EDIT:
Local port numbers changes with about a range of 49747 - 62749 while observable remote ports are roughly 6 namely 14301, 14400, 80, 14402, 27502, and 14401.


I'll just show you the process capture using process hacker. I may have missed a few connections.
Posted Image

Edited by momona, 05 July 2012 - 09:09 AM.


#5 Naj

Naj

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 06 July 2012 - 09:53 PM

it certainly fixed some of the black screen issues, although there still disconnections after a  period of time. this is kinda vexing.

#6 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 10 July 2012 - 09:08 AM

I'm just gonna paste this here as some people may see this. http://forum.cherryc...n/#entry1060342

#7 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 21 July 2012 - 04:43 AM

Bump for someone having the same problem.

#8 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 23 July 2012 - 08:09 AM

bump

#9 impakt07

impakt07

    Member

  • Members
  • PipPip
  • 14 posts

Posted 23 July 2012 - 02:22 PM

I have the same Problem too.. I'm using broadband connection via USB and the still work I can play the game on PVP but certain time after the battle I'm going disconnect, but my main problem is when I'm going out of the main city (e.g Saint haven, Calderock Village the game goes black screen as same as naj's problem... please can somebody help us or tell us why this happens? (sorry)

#10 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 23 July 2012 - 02:38 PM

View Postimpakt07, on 23 July 2012 - 02:22 PM, said:

I have the same Problem too.. I'm using broadband connection via USB and the still work I can play the game on PVP but certain time after the battle I'm going disconnect, but my main problem is when I'm going out of the main city (e.g Saint haven, Calderock Village the game goes black screen as same as naj's problem... please can somebody help us or tell us why this happens? (sorry)
You need to port forward ports to your computer. I don't know about broadband USBs though. If you can access the interface of the broadband USB, there may be an option for port forwarding.

#11 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 28 July 2012 - 08:12 AM

bump

#12 ameriichin

ameriichin

    Member

  • Members
  • PipPip
  • 23 posts
  • AmeriIchin
  • DN, Westwood
  • PsycoZ

Posted 01 August 2012 - 02:11 AM

during port fowarding. what should i do for :
  • application name
  • private ip
  • public ip
  • public port
  • private port
  • traffic type (TCP/UDP)

Edited by ameriichin, 01 August 2012 - 03:03 AM.


#13 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 01 August 2012 - 07:43 AM

View Postameriichin, on 01 August 2012 - 02:11 AM, said:

during port fowarding. what should i do for :
  • application name: Leave it blank

  • private ip: Your private IP address (inside your network)

  • public ip: 203.116.155.181, 203.116.155.131, 203.116.155.130, 203.116.155.163, 203.116.155.164 (one IP every entry)

  • public port: Range from 1 - 65535 would be better since port changes every run.

  • private port: Range from 1 - 65535 would be better since port changes every run.

  • traffic type (TCP/UDP): TCP


#14 ameriichin

ameriichin

    Member

  • Members
  • PipPip
  • 23 posts
  • AmeriIchin
  • DN, Westwood
  • PsycoZ

Posted 01 August 2012 - 12:02 PM

private ip is the one the default getaway rite?

#15 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 01 August 2012 - 12:08 PM

No. It's the other value.
Doing a ipconfig command will yield similar results:
C:\Users\Anonymous>ipconfig

Windows IP Configuration

Ethernet adapter LAN:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : <removed>
IPv4 Address. . . . . . . . . . . : 192.168.0.2 <- your private IP address
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1


#16 ameriichin

ameriichin

    Member

  • Members
  • PipPip
  • 23 posts
  • AmeriIchin
  • DN, Westwood
  • PsycoZ

Posted 01 August 2012 - 02:27 PM

it says the port being used?

#17 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 01 August 2012 - 04:35 PM

View Postameriichin, on 01 August 2012 - 02:27 PM, said:

it says the port being used?
Can you provide a screenshot of the port forwarding page on your router, along with its options? It would really help me in aiding you.

#18 ameriichin

ameriichin

    Member

  • Members
  • PipPip
  • 23 posts
  • AmeriIchin
  • DN, Westwood
  • PsycoZ

Posted 01 August 2012 - 06:16 PM

Posted Image

Posted Image

#19 momona

momona

    Advanced Member

  • Members
  • PipPipPip
  • 2598 posts
  • momona1412/MeshFile
  • DN, Greenwood
  • beakers

Posted 01 August 2012 - 11:39 PM

View Postameriichin, on 01 August 2012 - 06:16 PM, said:

Posted Image

Posted Image
Does it say "Port is used. Please check it." when you click "Save Settings"? Maybe you can check the checkbox on the first column.

Sorry for the late response. I dozed off and didn't check the forums.

Edited by momona, 01 August 2012 - 11:40 PM.


#20 ameriichin

ameriichin

    Member

  • Members
  • PipPip
  • 23 posts
  • AmeriIchin
  • DN, Westwood
  • PsycoZ

Posted 01 August 2012 - 11:42 PM

yup it says that.so what should i do?change a new port ?